Main Menu

Recent posts

#1
WebCopy / URL not writing to download fo...
Last post by FrankWard - April 11, 2024, 03:59:41 PM
I'm trying to download a blog. I've encountered several errors I was able to mitigate using regex. However, I'm not sure how to address this one.

When downloading the site it pulls various images from domains like.

http://3.bp.blogspot.com/_-sFohRgxOBI/R3natx-8SXI/AAAAAAAABiA/mp-2BeZnnYk/s1600-h/happy-new-year+Woody+Woodpecker.jpg

In the download folder it's not putting the domain as a folder. It's just writing a TON of the urls starting with the "_"character after the domain like so..

_-sFohRgxOBI/R3natx-8SXI/AAAAAAAABiA/mp-2BeZnnYk/s1600-h/happy-new-year+Woody+Woodpecker.jpg

This happens with the following domains, but not others, so it appears it may be a bug.

http://1.bp.blogspot.com/
http://2.bp.blogspot.com/
http://3.bp.blogspot.com/
http://4.bp.blogspot.com/

Is there a way to make the program remap these domains to specific folders in the downloaded site hierarchy?
Any advice? Thanks!
#2
WebCopy / How to auto skip warning of Ja...
Last post by IVAN_CYBERPUNK - April 05, 2024, 01:48:34 PM
Hi! I'm trying to make copy of some local web page using Cyotek WebCopy 1.10.0.898. After a little while app shows me message "This website appears to be a JavaScript application". After pressing "Ok" on warning screen - app starts to scan web page and successfully finished this process. I have no need to run this script, i'm only want to save web page as html file. So i wonder if is a solution to not press this button all the time? I will add warning screen and fragment of html file with this JavaScript. Thank you.
#3
WebCopy / Re: Rule to save HTML files on...
Last post by gary1854 - March 21, 2024, 06:05:58 PM
I tried this using application/pdf to download only pdf files from a site and it downloads nothing at all. 

Quote from: Richard Moss on February 23, 2023, 07:37:29 PMHello,

Thanks for the question. You don't need to use rules for this as there is a simpler approach

  • Open Project Properties (Project | Project Properties)
  • Select Content Types in the left hand tree
  • Click Include only resources with the content types listed below
  • In Types to include, enter
    text/html
  • Click OK to apply the changes and close the dialog
  • Copy the website

Regards;
Richard Moss
#4
WebCopy / Help copying single file forma...
Last post by gary1854 - March 20, 2024, 04:46:41 PM
Please help!
I have read the tutorial thoroughly on similar to what I want to achieve the tutorial where it shows you how to use rules to exclude all file types except image formats only I am trying to achieve the same but only for PDF format, I want to scan a whole site and only down PDF files From it It.  I am clearly doing something wrong using the rules feature only instead of using the image formats using my PDF format. It will ignore everything and download absolutely nothing at all, but I know that sees the files because if I don't use any rules at all until it to scan a site I can come back 12 hours later. It will still be scanning the site and will have already downloaded well over 1500 PDF files again all the PDF files all the files and everything else that's coming along with it and bloating my drive please someone is there a video on that tutorial where I could see it. I've tried looking through YouTube. I can't find anything if anyone can show me in a video of how exactly they're achieving this please let me know. Thank you. PS I have also tried not using rules and using the content type application/PDF and it doesn't find any PDF files but again I use no rules no exceptions. Nothing just the site all the PDF files just fine.
#5
Color Palette Editor / Re: Display a warning when the...
Last post by Richard Moss - March 17, 2024, 10:14:46 AM
Hello,

Thanks for the further feedback. I'd half forgotten that existed, I myself use the "Save Copy As" command which was added latter. The "general" Export was doing compatibility checks, but it lacked the context of knowing what the existing format was so it could only do basic checks on the new format (e.g. min / max colours). I've reworked the flow so it has the additional context and now it can run the full set of checks.

This will be present in 1.8.0.484 or higher.

The "general" Export dialog flow is a little annoying so at some point I'll tweak that further.

Regards;
Richard Moss

Edit: Fixed build number
#6
Color Palette Editor / Re: Display a warning when the...
Last post by desbest - March 16, 2024, 11:28:33 AM
Thank you for your help.

However while the warnings display when using "save as", it doesn't appear when using the "export wizard" feature.
#7
WebCopy / Changing image route from URL ...
Last post by nanarumi - March 15, 2024, 08:38:18 AM
Hello everyone,
I've been using WebCopy recently for my website and I need insight on something.
Is there a way to change the image route setting before proceeding with the copy process?
Because I want to change the image route from URL link to local folder

Here is the code snippet from my downloaded HTML file.
<meta name="image" content="https://archbee-image-uploads.s3.amazonaws.com/ZHvSjR5ZrsoxwKbJa3xmo/4WwgM-hG8zMTp2CmIYFrP_rdrx9d8diazpgm07xfz2test-1.png">
The local folder name is ZHvSjR5ZrsoxwKbJa3xmo.

Thanks in advance.
#8
WebCopy / Re: SSL/TLS error: Could not e...
Last post by darren - March 07, 2024, 06:48:02 PM
i have this same exact issue as described. same version.
#9
Color Palette Editor / Re: Display a warning when the...
Last post by Richard Moss - February 29, 2024, 10:52:43 AM
Hello,

Thanks for the bug report. Warnings should have been displayed but there was a nice subtle bug causing them sometimes not to be displayed. However, there wasn't an explicit warning regarding swatch names, so I've added one of these too.

This will be present in 1.8.0.482 or higher.

Regards;
Richard Moss
#10
Color Palette Editor / Re: HEX colours not being kept...
Last post by Richard Moss - February 29, 2024, 10:07:20 AM
Hello,

This is a problem with the editing components the Palette Editor uses, there seems to be an error in precision or rounding when converting between RGB and HSL. I can reproduce the issue, so just need to do some more diagnostics then come up with an appropriate fix.

Regards;
Richard Moss