Registering legacy Interface Components 1.3 OCX on Win 7 64 bits

Started by makafre, August 03, 2015, 10:26:24 PM

Previous topic - Next topic

makafre

Hi everyone,

I have to make changes into a VB 6 application that includes interface13m (Ariad Interface Components 1.3) but it fails to install correctly... I know it`s normal as it has been a while since this product was published!  However, as its not an option for me to not use it this time again, I am asking for your help.

This is what I think should have made the ocx file to register correctly:

- Disabled UAC and rebooted
- Ran `cmd` using administrator rights
- Executed:   C:\Windows\SysWOW64\regsvr32 C:\Windows\SysWOW64\AS-IFce1.ocx

...but even if I get a successfull message from regsvr32, VB 6 complains that Object library is not registered (AS-IFce1.ocx)

Any idea besides scraping my laptop and going to XP 32 bits?

Thanks a mil!






Richard Moss

I don't think I'd ever recommend turning UAC off, just running cmd as admin should have been sufficient.

Seems a bit strange that it doesn't work - after all, the VB6 runtime is still supported and must work in 64bit. Hell, I know it does because I have another machine (Windows 10 64bit) that has a VB5 application running on it!

As none of my VM's are 64bit, I extracted the old demo program and the OCX from backups and stuck them on my freshly-upgraded Windows 10 Pro machine as this is 64bit. With UAC enabled ;)

I registered the OCX via an admin command prompt, then ran the demo. To my utter shock it actually runs!



Anyway, it runs for me, which doesn't exactly help you. However, I just ran regsvr32.exe and allowed it to be used via the path. When I did a WHERE regsvr32.exe it reported that it was being run from System32 - maybe you could try running that version rather than the SysWOW64 version?

Regards;
Richard Moss