Gif Animator foe WinXP

Started by CryoDave, November 20, 2016, 09:25:04 PM

Previous topic - Next topic

CryoDave

Is there a Gif Animator that runs in WinXP?

Richard Moss

Hello, welcome to the forums.

Version 0.0.6.0 and below should work on XP as they are compiled against the now discontinued .NET 3.5. Version 0.0.7.0 onward (the "nightly" builds) are compiled using .NET 4.6 and will not work on XP.

At this point in time I do not anticipate creating any more builds that are compatible with XP, but I've been known to change my mind before!

Regards;
Richard Moss

CryoDave

Thanks for the reply. Can you tell me where to get the 0.0.6.0 version. Thanks

Richard Moss


CryoDave

I downloaded that copy ( a copy ) and it wants .Net 4.5.2 to run. I tried to run it a few times and the same results happened. the file I downloaded was "setup-cyogifan-0.0.6.0-beta.exe". As far as I can tell .Net 3.5 is on my machine and has gotten some updates. The attached image is the modal screen that comes up as I install the program.

Richard Moss

Hello,

Thanks for the follow up. I checked 0.0.6 and as you pointed out I was mistaken and it does required 4.5.2. I checked 0.0.5.2 on a Windows XP VM and this runs fine on that, so that version is compiled against either .NET 3.5 or 4.0. They are quite old builds so I don't recall the specifics.

Unfortunately, as I mentioned I don't have any plans to support Windows XP going forward and as Gif Animator is still very much in progress, it's highly likely these old builds have issues resolved by newer versions.

Regards;
Richard Moss

CryoDave

 I've downloaded 0.0.5.2. It setup fine so far!!! I haven't had a chance to try it out yet. Thanks again.