Inconsistencies with authentication

Started by PoetikDragon, March 16, 2022, 10:50:52 PM

Previous topic - Next topic


I am trying to backup the content of an independently hosted WordPress site with almost all of the content requiring an authenticated user. Whenever authentication fails, the request is redirected to another page saying membership level is too low. At first, I struggled because WebCopy was hitting the logout page and logging out, but I have now added a rule for that. However, no matter what combination of settings I do, I get about half of the pages redirecting to the "membership level too low" page during copy. It is always the same pages, but it happens in between other pages that work fine.

I have tried:
- Excluding the logout page (absolutely necessary but not a 100% fix)
- Capturing the login form with my credentials (doesn't work at all -- testing the form gives weird results too?)
- Enabling "Log in using web browser" (most successful)
- Enabling "Use web browser" (seems to work better disabled)
- Enabling "Don't follow redirects" (no effect whatsoever -- all redirects still followed)
- Checking or not checking "remember me" on the login form (no effect)

I would like to try adding cookies manually from my browser but the documentation on it is so sparse that I have no idea where to begin.

I also could find no way to clear the cache, if that is the problem with the redirects. Since some pages randomly work, and its always the same pages that work or redirect, I really wonder if this is the problem.

I have noticed that after it completes a copy, if I run the copy command again (with "log in using web browser" enabled) it still logged in. I have tried letting this continue unchanged, as well as logging out and logging back in.

I have no access to the backend and we're going to lose hosting on 4/1 so I would appreciate any assistance or ideas.