Main Menu

Extension changing to .txt

Started by alfsone, February 10, 2021, 11:33:46 PM

Previous topic - Next topic

alfsone

Hi,

surely a newbie question, anyway...

My first attempt to copy a web site, this one: http://bhs.minor9.com/biab/jazz/%23/

Now, my problem: all the files there, that have an .mgu extension (sound files for Band in a Box) are changed in .mgu.txt in my local copy.

Is there a way NOT to change the extension, leaving the .mgu extension as in the original?

Thanks
Alfredo

Richard Moss

I already responded to your support ticket on the subject, but I'll post the answer here as well for any other visitors

The reason why WebCopy is adding the .txt extension is because this server is reporting the content type of the .mgu files as text/plain. This is a configuration error on the server itself.

You can tell WebCopy not to map file extensions. In your example, you could disable extension mapping for .mgu files by

* Opening the properties for your copy
* Select the Local Files category
* In the Types to Exclude field (assuming you are using the default values), enter mgu
* Click OK to save the changes and close the dialog

For more information, please see the following documentation topic:
https://docs.cyotek.com/cyowcopy/current/settingsremapextensions.html

alfsone


ambizop

i was also looking for the same, thanks for the answer