Error on creating site map

Started by Penge58, July 04, 2018, 08:14:57 PM

Previous topic - Next topic

Penge58


Hello

I am new here and hope this forum is active so that someone can help me with a problem I have with Site Map Creator.

I let the software scan my webshop but it seems that all images in JPG format creates an error (Invalid Content Type)

What have I done wrong ?

Se attached screendump.

Regards Petter

Richard Moss

Hello,

Welcome to the forums, I'm sorry to hear you're having troubles with Sitemap Creator.

The screenshot you show indicates the normal behaviour of the software - it is skipping images as there's nothing it can do with them, e.g. it doesn't download them and it can't scan them for links as with HTML documents.

If you're trying to include the images in your sitemap itself you would need to create a rule for *\.jpg (or png, etc) with the Include Images flag set.

Hope this helps, please let me know if you need further information.

Regards;
Richard Moss

Penge58

Hello and thanks for your reply.

So it will still create the sitemap even if with these errors ?

Petter

Richard Moss

Hello,

Yes it should. These aren't errors as such, although I admit that it could be clearer. That tab basically is a crawl log, and it's showing that it has skipped these files as not being valid for the current action, e.g. building a map of the website. It still records them though, and so will appear in the sitemap if a rule is present with the images flag. Or at least they should...

Regards;
Richard Moss

Penge58

Thank you again but what bothers me is that it ends up showing a pop up message saying that the scanning was canceled.
You see the message on my attachment.
It was not me who canceled the scanning but the software itself.
I let it run by itself for quite a time and when I come back I saw this message.
I assume it did not finished the scanning and though did not create the sitemap ??

Richard Moss

Hello,

Apologies, I'm looking at this image on a Surface tablet and I didn't actually notice the message prompt - it's almost fully off screen, and as your message referred to the skipped items that is what I focused on.

The software shouldn't cancel automatically, this indicates something has crashed in the wrong place.

Firstly, can you confirm which version of Sitemap Creator you're using.

Secondly, if you look in the Errors tab, what is displayed there? If you double click the items in the list there should be a Report link if any of the errors were the result of a crash - try submitting this which will send me an error report I can look at.

Sorry for the initial confusion.

Regards;
Richard Moss

Penge58

I am using 1.0.6.1

I will look at the error tab and post it here

Penge58

It says that the operation was timed out.

Does it means that my server was responding too slow ?
Can I adjust the timeout value ?


Petter

Richard Moss

Hello,

There currently isn't a way to set the timeout, but you can set some naive limits to slow the crawl down a little. You can set these by opening the project properties, expanding the Advanced node and selecting the Limits category.

The version of the Sitemap Creator you are using is very old and is missing a great many bug fixes as the crawl engine has evolved in WebCopy.

Regards;
Richard Moss

Penge58

Oh....can you please post the link were I can download the latest version ?

Penge58

When I use the option to check for updates it tells me that I am using the latest version

Richard Moss

Hello,

By default when you check for updates it checks only for stable versions. I haven't really had a lot of time to focus on Sitemap Creator for some time due to working on WebCopy and so it's been neglected for a while now. There's been so many changes I haven't had time to thoroughly test it before creating a stable release.

You can download Sitemap Creator from this URL:
https://www.cyotek.com/cyotek-sitemap-creator/downloads

Nightly builds are the most up to date, but they are created via an automated process and so they may break. You can grab the latest beta version though.

Regards;
Richard Moss

Penge58

Thank you again for our response.

I have now downloaded and installed the latest beta which is version 1.2.0.456
However it does not scan my site.
It only shows the two addresses "www.strazz.no" and "strazz.no" and nothing more.
Its all done in a second.

What is wrong with this version ?

Penge58

I just installed the latest nightly build and that version is scanning now so lets see

Richard Moss

Hello,

Thanks for letting know about the issue with the beta. This rings a bell, but I can't remember the exact circumstances of the cause. Evidently I found and fixed something though if the latest versions aren't affected. As soon as WebCopy 1.5 is released I'll spend some time getting the Sitemap Creator up to date.

Regards;
Richard Moss